加入收藏 | 设为首页 | 会员中心 | 我要投稿 辽源站长网 (https://www.0437zz.com/)- 云专线、云连接、智能数据、边缘计算、数据安全!
当前位置: 首页 > 大数据 > 正文

LightOJ1214 Large Division (大数求余,同余定理)

发布时间:2021-01-09 10:20:32 所属栏目:大数据 来源:网络整理
导读:Given two integers, a and b ,you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c . Input Input starts with an integer T (

Given two integers,a and b,you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.


Input

Input starts with an integer T (≤ 525),denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0,b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case,print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

#include<stdio.h>
#include<string.h>
int main()
{
	int T,j=1;
	scanf("%dn",&T);
	while(T--){
		long long a,ans=0;
		char str[300];
		scanf("%s %lld",str,&a);
		int len = strlen(str);
		if(a<0)
		a=-a;
		for(int i=0;i<len;i++){
			if(str[i]=='-')
			continue;
			ans=(ans*10+str[i]-'0')%a;
		}
		if(ans==0)
		printf("Case %d: divisiblen",j++);
		else
		printf("Case %d: not divisiblen",j++);
	}
return 0;
}

(编辑:辽源站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读